[libcxx-commits] [PATCH] D61170: Use std::move in numeric algorithms

Zoe Carver via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Wed May 1 13:57:04 PDT 2019


zoecarver updated this revision to Diff 197631.
zoecarver added a comment.

- Update tests to make them more readable and visually correct.
- Add tests for` std::string` (a thing the paper focuses on).

I originally wanted to use `TrackedValue` or another pre-built struct instead of `rvalue_addable`, but they all required so much modification / overriding that it seemed easier to just create a new one.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D61170/new/

https://reviews.llvm.org/D61170

Files:
  include/numeric
  test/std/numerics/numeric.ops/accumulate/accumulate_op.pass.cpp
  test/std/numerics/numeric.ops/adjacent.difference/adjacent_difference_op.pass.cpp
  test/std/numerics/numeric.ops/inner.product/inner_product_comp.pass.cpp
  test/std/numerics/numeric.ops/partial.sum/partial_sum_op.pass.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D61170.197631.patch
Type: text/x-patch
Size: 12647 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/libcxx-commits/attachments/20190501/fa45a25a/attachment.bin>


More information about the libcxx-commits mailing list