[cfe-users] segmentation fault 11 when running clang-tidy

Hongping Lim via cfe-users cfe-users at lists.llvm.org
Mon Jan 11 19:29:14 PST 2016

I tried running the command on some other files, and managed to get it
working once, and then it segfaulted again when I ran the same command
right after.

Suppressed 217 warnings (217 in non-user code).
Use -header-filter=.* to display errors from all non-system headers.
hongping at HLim-MBP:~/my/project$ ../build/bin/clang-tidy -checks=* ./MyFile.m
clang-tidy(3670,0x7fff71f9b000) malloc: *** error for object
0x7fcf20000007: pointer being realloc'd was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap: 6

On Mon, Jan 11, 2016 at 5:57 PM, Hongping Lim <hongping.lim at gmail.com>

> I am on Mac OS X 10.11.1, and downloaded the sources and followed the
> instructions to build clang-tidy. I used xcodebuild and xcpretty to
> generate the compile_commands.json file. I have the json file in my project
> root, and ran:
> ~/build/bin/clang-tidy ./MyFile.m
> Initially I got this error "LLVM ERROR: unknown module format", and after
> some Googling, tried to delete all the fmodule and gmodule parameters from
> the json file.
> After that, I keep getting "Segmentation fault: 11" most of the time.
> There was once when I was able to get the list of warnings, but when I run
> the same command right after, I get the segmentation fault again.
> Thanks,
> Hongping
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-users/attachments/20160111/ba8b70cc/attachment.html>

More information about the cfe-users mailing list