<div dir="ltr">I'm working on adding some matchers support to libclang however I'm quiet confused with the preferred naming conventions<div><br></div><div>Current function naming:</div><div> * clang_<c_type>_<method> (e.g. clang_CXCursorSet_insert)</div><div> * clang_<c++type>_<method> (e.g. upper: clang_Cursor_getArgument lower: clang_index_getClientEntity )</div><div> * clang_get<type><attr> (e.g. clang_getDiagnosticInSet)</div><div> </div><div>Dispose and create seems a little more consistent with prefix of clang_create/clang_dispose however there are some which use dispose/create suffix (e.g. clang_IndexAction_*, clang_remap_*)</div><div><br></div><div>Even variable names for functions are consistent:<br> * No names at all (clang_remap_dispose(CXRemapping))</div><div> * Underscore names (e.g. unsigned index_options)</div><div> * Camel case upper (e.g. unsigned NumTokens)</div><div> * Camel case lower (e.g. unsigned *isGenerated)</div><div><br></div><div>With all of these different alternatives what should be used for new code?</div></div>