<div dir="ltr"><br><br><div class="gmail_quote"><div dir="ltr">On Thu, Dec 29, 2016 at 10:04 AM Mehdi Amini via cfe-dev <<a href="mailto:cfe-dev@lists.llvm.org">cfe-dev@lists.llvm.org</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word" class="gmail_msg"><div class="gmail_msg"><blockquote type="cite" class="gmail_msg"><div class="gmail_msg">On Dec 29, 2016, at 5:54 AM, Daniel Berlin <<a href="mailto:dberlin@dberlin.org" class="gmail_msg" target="_blank">dberlin@dberlin.org</a>> wrote:</div><br class="m_1399359644854761192Apple-interchange-newline gmail_msg"><div class="gmail_msg"><div dir="ltr" class="gmail_msg"><div class="gmail_extra gmail_msg"><div class="gmail_quote gmail_msg"><blockquote class="gmail_quote gmail_msg" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr" class="gmail_msg"><br class="gmail_msg"><div class="gmail_msg">>From yesterday discussion, Daniel Berlin proposed using emplace_back everywhere to make code easier to maintain. I think it is valid argument, but I believe it would reduce readability.</div></div></blockquote><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">Just to be clear; I proposed not trying to switch uses back and forth without real data, and to come to some agreement about what should be written in the first place, preferably based on real data, and then, switching in some organized fashion, not just randomly :)</div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">IE Either have a clear coding standard and enforce it, or leave uses alone one way or the other without some demonstration that it actually matters.</div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">I would *personally* prefer to just use emplace_back everywhere, and not try to switch between the two, without demonstration of real benefit.</div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">(i'd also accept the other way, use push_back everywhere, and not try to switch between the two, without demonstration of real benefit).</div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">This preference is based on a simple truth: People suck at deciding when to use one or the other. Yes, i know how to use it and when to use it.  Lots of our types are cheaply movable, etc, so you probably won't see any performance difference even when using them "right".  People have enough style/etc issues without having to try to think hard about this.</div></div></div></div></div></blockquote><div class="gmail_msg"><br class="gmail_msg"></div></div></div><div style="word-wrap:break-word" class="gmail_msg"><div class="gmail_msg"><div class="gmail_msg">I agree that “people suck at deciding”, me in the first place in the line, and that’s why I like clear and good guideline and stick to it unless "demonstration of real benefit”.</div><div class="gmail_msg">I also think we can have clear guideline that are different from “always use emplace_back” or “always use push_back”, like Piotr is suggesting.</div></div></div></blockquote><div><br></div><div>I don't think Piotr is suggesting "always use push_back" but "always use push_back when it's valid" & I'd second this.<br><br>To show a simpler example:<br><br>std::unique_ptr<T> u(v);<br><br>std::unique_ptr<T> u = v;<br><br>I'd generally advocate for using copy init (the second form - it doesn't copy in this case, it moves) over direct init (the first form) because it's more legible - copy init can only execute implicit ctor operations, whereas direct init can invoke implicit and explicit operations. So from a readability perspective seeing the latter is easier than seing the former - I know the operation is further constrained to simpler/less interesting operations (eg: 'v' can't be a raw pointer in the second form, it might be (& then I have to worry about whether that's an ownership transfer that's intended), etc)<br><br>& push_back V emplace_back is the same choice - push_back means only implicit ops are used and so it's more readable, emplace_back requires more careful attention.<br><br>I think this is a reasonably good stylistic rule - but I'm happy leaving an open to judgment for sure - there might be readability reasons that an emplace_back may work better in some cases.<br><br>I'd think of this like "else after return" - we don't have any enforcement, sometimes we make judgment about it being better (for consistency - sometimes there's a pattern such that else makes the code more readable), we haven't gone back to do any cleanup of the codebase, but it's pretty consistently applied/desired in code review.<br><br>All that said - sure, I'd like to have tools to help me get this right (else after return and "prefer copy init style over direct init") & make that really easy to do.<br><br>- Dave</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word" class="gmail_msg"><div class="gmail_msg"><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">That said, I’m not convinced the relative “ugliness" of emplace_back  (I’m not sure what’s ugly there, I only see it as a habit to take)  vs push_back is enough to justify a set of rules to decide between the two, I’d be fine with “always using emplace_back” in the name of “simple rule is better when possible".</div><div class="gmail_msg"><br class="gmail_msg"></div><blockquote type="cite" class="gmail_msg"><div class="gmail_msg"><div dir="ltr" class="gmail_msg"><div class="gmail_extra gmail_msg"><div class="gmail_quote gmail_msg"></div></div></div></div></blockquote></div></div><div style="word-wrap:break-word" class="gmail_msg"><div class="gmail_msg"><blockquote type="cite" class="gmail_msg"><div class="gmail_msg"><div dir="ltr" class="gmail_msg"><div class="gmail_extra gmail_msg"><div class="gmail_quote gmail_msg"><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">So that isn't what I would necessarily propose for LLVM.</div><div class="gmail_msg"><br class="gmail_msg"></div></div></div></div></div></blockquote></div></div><div style="word-wrap:break-word" class="gmail_msg"><div class="gmail_msg"><blockquote type="cite" class="gmail_msg"><div class="gmail_msg"><div dir="ltr" class="gmail_msg"><div class="gmail_extra gmail_msg"><div class="gmail_quote gmail_msg"><div class="gmail_msg">For LLVM, my answer would be "either make tool do what we want, force use of tool, or be consistent and obvious with what we want and then fix it if it leads to performance issue”</div></div></div></div></div></blockquote><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">+1</div><div class="gmail_msg">Ultimately whatever we do is not practical if it can’t be done by a tool.</div></div></div></blockquote><div><br></div><div>Not sure I follow this - we have lots of things we don't currently do with a tool that's still part of our style & stuff we try to catch with code review, etc. (else after return is my best example)</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word" class="gmail_msg"><div class="gmail_msg"><div class="gmail_msg"><br class="gmail_msg"></div><br class="gmail_msg"><blockquote type="cite" class="gmail_msg"><div class="gmail_msg"><div dir="ltr" class="gmail_msg"><div class="gmail_extra gmail_msg"><div class="gmail_quote gmail_msg"><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg"> </div><blockquote class="gmail_quote gmail_msg" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr" class="gmail_msg"><div class="gmail_msg">There is also other reason - emplace_back can't take arguments of some types like bitfields, NULL, static member. Using emplace can also lead to memory leak in case of smart ptrs</div><div class="gmail_msg">"</div><div class="gmail_msg"><pre style="overflow-x:auto;overflow-y:hidden;border-color:rgb(12,55,98);border-style:dotted;border-width:thin;margin-top:0px;margin-bottom:12px;padding:0.8em;background-color:rgb(240,240,240);color:rgb(51,51,51)" class="gmail_msg"><span class="m_1399359644854761192m_4359502425263540212gmail-k gmail_msg" style="color:rgb(0,112,32);font-weight:bold">auto</span> <span class="m_1399359644854761192m_4359502425263540212gmail-o gmail_msg" style="color:rgb(102,102,102)">*</span><span class="m_1399359644854761192m_4359502425263540212gmail-n gmail_msg">ptr</span> <span class="m_1399359644854761192m_4359502425263540212gmail-o gmail_msg" style="color:rgb(102,102,102)">=</span> <span class="m_1399359644854761192m_4359502425263540212gmail-k gmail_msg" style="color:rgb(0,112,32);font-weight:bold">new</span> <span class="m_1399359644854761192m_4359502425263540212gmail-kt gmail_msg" style="color:rgb(144,32,0)">int</span><span class="m_1399359644854761192m_4359502425263540212gmail-p gmail_msg">(</span><span class="m_1399359644854761192m_4359502425263540212gmail-mi gmail_msg" style="color:rgb(64,160,112)">1</span><span class="m_1399359644854761192m_4359502425263540212gmail-p gmail_msg">);</span>
<span class="m_1399359644854761192m_4359502425263540212gmail-n gmail_msg">v</span><span class="m_1399359644854761192m_4359502425263540212gmail-p gmail_msg">.</span><span class="m_1399359644854761192m_4359502425263540212gmail-n gmail_msg">push_back</span><span class="m_1399359644854761192m_4359502425263540212gmail-p gmail_msg">(</span><span class="m_1399359644854761192m_4359502425263540212gmail-n gmail_msg">std</span><span class="m_1399359644854761192m_4359502425263540212gmail-o gmail_msg" style="color:rgb(102,102,102)">::</span><span class="m_1399359644854761192m_4359502425263540212gmail-n gmail_msg">unique_ptr</span><span class="m_1399359644854761192m_4359502425263540212gmail-o gmail_msg" style="color:rgb(102,102,102)"><</span><span class="m_1399359644854761192m_4359502425263540212gmail-kt gmail_msg" style="color:rgb(144,32,0)">int</span><span class="m_1399359644854761192m_4359502425263540212gmail-o gmail_msg" style="color:rgb(102,102,102)">></span><span class="m_1399359644854761192m_4359502425263540212gmail-p gmail_msg">(</span><span class="m_1399359644854761192m_4359502425263540212gmail-n gmail_msg">ptr</span><span class="m_1399359644854761192m_4359502425263540212gmail-p gmail_msg">));</span></pre></div><div class="gmail_msg"><p style="text-align:justify;color:rgb(51,51,51);font-family:"dejavu sans",arial,helvetica,sans-serif;font-size:14.4px" class="gmail_msg">This is because replacing it with <code class="m_1399359644854761192m_4359502425263540212gmail-docutils m_1399359644854761192m_4359502425263540212gmail-literal gmail_msg" style="background-color:rgb(226,226,226);font-size:1em"><span class="m_1399359644854761192m_4359502425263540212gmail-pre gmail_msg">emplace_back</span></code> could cause a leak of this pointer if <code class="m_1399359644854761192m_4359502425263540212gmail-docutils m_1399359644854761192m_4359502425263540212gmail-literal gmail_msg" style="background-color:rgb(226,226,226);font-size:1em"><span class="m_1399359644854761192m_4359502425263540212gmail-pre gmail_msg">emplace_back</span></code> would throw exception before emplacement (e.g. not enough memory to add new element).".</p></div></div></blockquote><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">This seems, IMHO, not a useful argument for LLVM since it does not try to use exception based error handling to recover.</div></div></div></div></div></blockquote></div></div><div style="word-wrap:break-word" class="gmail_msg"><div class="gmail_msg"></div><br class="gmail_msg"><div class="gmail_msg">This, and also we should not write code like that (naked pointers, calling new), using make_unique<> for instance would prevent any such situation. Passing a raw pointer to a container of unique_ptr can be flagged by a tool.</div></div></blockquote><div><br></div><div>Sure - but it generalizes further than that, it's just a nice simple example.<br><br>std::vector<int> v(i);<br><br>'i' could be an int & this would make a vector of that many ints, or it could be another vector & this is making a copy, etc.<br><br>std::vector<int> v = i;<br><br>I know taht's not creating a vector of 'i' many ints.<br><br>Yeah, not a great example either - but the general idea applies, the latter form is less powerful & so is easier to read because you don't have to worry/think about it as much.<br><br>I think we mostly do this sort of thing out of habit anyway - but codifying it (& if possible, tools to help) could be nice.<br><br></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word" class="gmail_msg"><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">— </div></div><div style="word-wrap:break-word" class="gmail_msg"><div class="gmail_msg">Mehdi</div></div>_______________________________________________<br class="gmail_msg">
cfe-dev mailing list<br class="gmail_msg">
<a href="mailto:cfe-dev@lists.llvm.org" class="gmail_msg" target="_blank">cfe-dev@lists.llvm.org</a><br class="gmail_msg">
<a href="http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev" rel="noreferrer" class="gmail_msg" target="_blank">http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-dev</a><br class="gmail_msg">
</blockquote></div></div>