<div dir="ltr">As far as I can see, the check does not include any <span style="background-color:initial;color:rgb(51,51,51)">FixItHint</span> yet that I have already implemented for most of the cases. Kirill is it OK for you, if I keep continuing this and provide a patch? <br><div><br></div><div>Regarding differences between CERT and CppCore: </div><div>How about providing a general readability-checker that splits up any init-declarator list into single init-declarators? Then, we may provide "pseudo" cert-one-name-per-declaration and cppcore-one-name-per-declaration checks which will register the general readability checker and use Options to pass the config paramer (cert and cppcore) to the general check. </div><div><br></div><div>Something like:</div><div><br></div><div>// ReadabilityTidyModule.cpp</div><div><div><div>CheckFactories.registerCheck<OneNamePerDeclarationCheck>("readability-one-name-per-declaration");</div><div><br></div><div>// CERTTidyModule.cpp</div><div>CheckFactories.registerCheck<readability::OneNamePerDeclarationCheck>("cert-one-name-per-declaration");</div><div><br></div><div>ClangTidyOptions getModuleOptions() override {</div><div>    ClangTidyOptions Options;</div><div>    auto &Opts = Options.CheckOptions;</div><div>    Opts["cert-one-name-per-declaration.style"] = "cert";</div><div>    return Options;</div><div>}</div><div><br></div><div>// CppCoreGuidelinesModule.cpp</div><div>CheckFactories.registerCheck<readability::OneNamePerDeclarationCheck>("cppcoreguidelines-one-name-per-declaration");</div><div><br></div><div>ClangTidyOptions getModuleOptions() override {</div><div>    ClangTidyOptions Options;</div><div>    auto &Opts = Options.CheckOptions;</div><div>    Opts["cert-one-name-per-declaration.style"] = "ccpcore";</div><div>    return Options;</div><div>}</div></div></div><div><br></div><div>Any thoughts on this?</div><div><br></div><div><br></div></div><div class="gmail_extra"><br><div class="gmail_quote">2016-10-21 17:18 GMT+02:00 Malcolm Parsons <span dir="ltr"><<a href="mailto:malcolm.parsons@gmail.com" target="_blank">malcolm.parsons@gmail.com</a>></span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">On 21 October 2016 at 16:06, Firat Kasmis via cfe-dev<br>
<span class=""><<a href="mailto:cfe-dev@lists.llvm.org">cfe-dev@lists.llvm.org</a>> wrote:<br>
> I would like to know if there is any need for a readability check that<br>
</span>> checks for multiple declarations in one statement (init-declarator list.<br>
<br>
Kirill Bobyrev is working on one.<br>
See <a href="https://reviews.llvm.org/D25024" rel="noreferrer" target="_blank">https://reviews.llvm.org/<wbr>D25024</a><br>
<span class="HOEnZb"><font color="#888888"><br>
--<br>
Malcolm Parsons<br>
</font></span></blockquote></div><br></div>