<html><head><meta http-equiv="Content-Type" content="text/html charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class="">Hi Firat,<div class=""><br class=""></div><div class="">Sure, go ahead!</div><div class=""><br class=""></div><div class="">Unfortunately, I don’t have much time at the moment.</div><div class=""><br class=""></div><div class="">I would suggest to enhance CppCoreGuidelines rule too: I think it’s currently not restrictive and precise enough. I’ve opened an Issue [0] on Github; sadly, there’s no feedback yet.</div><div class=""><br class=""></div><div class="">—</div><div class="">Kirill</div><div class=""><br class=""></div><div class="">[0] <a href="https://github.com/isocpp/CppCoreGuidelines/issues/770" class="">https://github.com/isocpp/CppCoreGuidelines/issues/770</a></div><div class=""><br class=""><div><blockquote type="cite" class=""><div class="">On 24 Oct 2016, at 14:41, Firat Kasmis <<a href="mailto:firat.kasmis@gmail.com" class="">firat.kasmis@gmail.com</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><div dir="ltr" class="">As far as I can see, the check does not include any <span style="background-color:initial;color:rgb(51,51,51)" class="">FixItHint</span> yet that I have already implemented for most of the cases. Kirill is it OK for you, if I keep continuing this and provide a patch? <br class=""><div class=""><br class=""></div><div class="">Regarding differences between CERT and CppCore: </div><div class="">How about providing a general readability-checker that splits up any init-declarator list into single init-declarators? Then, we may provide "pseudo" cert-one-name-per-declaration and cppcore-one-name-per-declaration checks which will register the general readability checker and use Options to pass the config paramer (cert and cppcore) to the general check. </div><div class=""><br class=""></div><div class="">Something like:</div><div class=""><br class=""></div><div class="">// ReadabilityTidyModule.cpp</div><div class=""><div class=""><div class="">CheckFactories.registerCheck<OneNamePerDeclarationCheck>("readability-one-name-per-declaration");</div><div class=""><br class=""></div><div class="">// CERTTidyModule.cpp</div><div class="">CheckFactories.registerCheck<readability::OneNamePerDeclarationCheck>("cert-one-name-per-declaration");</div><div class=""><br class=""></div><div class="">ClangTidyOptions getModuleOptions() override {</div><div class="">    ClangTidyOptions Options;</div><div class="">    auto &Opts = Options.CheckOptions;</div><div class="">    Opts["cert-one-name-per-declaration.style"] = "cert";</div><div class="">    return Options;</div><div class="">}</div><div class=""><br class=""></div><div class="">// CppCoreGuidelinesModule.cpp</div><div class="">CheckFactories.registerCheck<readability::OneNamePerDeclarationCheck>("cppcoreguidelines-one-name-per-declaration");</div><div class=""><br class=""></div><div class="">ClangTidyOptions getModuleOptions() override {</div><div class="">    ClangTidyOptions Options;</div><div class="">    auto &Opts = Options.CheckOptions;</div><div class="">    Opts["cert-one-name-per-declaration.style"] = "ccpcore";</div><div class="">    return Options;</div><div class="">}</div></div></div><div class=""><br class=""></div><div class="">Any thoughts on this?</div><div class=""><br class=""></div><div class=""><br class=""></div></div><div class="gmail_extra"><br class=""><div class="gmail_quote">2016-10-21 17:18 GMT+02:00 Malcolm Parsons <span dir="ltr" class=""><<a href="mailto:malcolm.parsons@gmail.com" target="_blank" class="">malcolm.parsons@gmail.com</a>></span>:<br class=""><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">On 21 October 2016 at 16:06, Firat Kasmis via cfe-dev<br class="">
<span class=""><<a href="mailto:cfe-dev@lists.llvm.org" class="">cfe-dev@lists.llvm.org</a>> wrote:<br class="">
> I would like to know if there is any need for a readability check that<br class="">
</span>> checks for multiple declarations in one statement (init-declarator list.<br class="">
<br class="">
Kirill Bobyrev is working on one.<br class="">
See <a href="https://reviews.llvm.org/D25024" rel="noreferrer" target="_blank" class="">https://reviews.llvm.org/<wbr class="">D25024</a><br class="">
<span class="HOEnZb"><font color="#888888" class=""><br class="">
--<br class="">
Malcolm Parsons<br class="">
</font></span></blockquote></div><br class=""></div>
</div></blockquote></div><br class=""></div></body></html>