<html><head><meta http-equiv="Content-Type" content="text/html charset=windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div><div>On Dec 21, 2012, at 1:18 PM, Chandler Carruth <<a href="mailto:chandlerc@gmail.com">chandlerc@gmail.com</a>> wrote:</div><blockquote type="cite"><div style="font-family: arial, helvetica, sans-serif; font-size: 10pt"><div dir="ltr"><div class="gmail_default" style="">So, last time I tried, I needed a bit more tooling in place to do the renaming sanely. =] That's taken care of, and so I'm hoping to do the renaming from 'clang/lib/CodeGen/...' to 'clang/lib/IRGen/...' over the holidays (hopefully minimal patches outstanding).</div>
<div class="gmail_default" style=""><br></div><div class="gmail_default" style="">I'm also going to try to systematically clean up the naming of files and classes.</div><div class="gmail_default" style=""><br></div><div class="gmail_default" style="">
The current leading strategy for files:</div><div class="gmail_default" style=""><br></div><div class="gmail_default" style="">  lib/CodeGen/CGCall.cpp -> lib/IRGen/Call.cpp</div><div class="gmail_default" style="">  lib/CodeGen/CodeGenFunction.cpp -> lib/IRGen/Function.cpp</div>
<div class="gmail_default" style=""><br></div><div class="gmail_default" style="">The current leading strategy for classes:</div><div class="gmail_default" style=""><br></div><div class="gmail_default" style="">  clang::CGFoo -> clang::irgen::Foo</div>
<div class="gmail_default" style="">  clang::CodeGenBar -> clang::irgen::Bar</div><div class="gmail_default" style=""><br></div><div class="gmail_default" style="">I'm asking Doug and John to paint this bikeshed so that we don't just go around in circles endlessly.</div>
</div></div>
</blockquote></div><br><div>I really like having a prefix on file names so that they aren't immediately confusable — visually, by IDEs, by C-x b, etc. — with files from other parts of the compiler.  For example, I think it would be a real loss if there were three Decl.cpp files in clang: one in AST, one in Sema, and one in IRGen.</div><div><br></div><div>For lack of a better idea, let's go with replacing everything that's "CodeGen" with "IRGen" and "CG" with "IR".  "IR" has a pretty unambiguous meaning in the context of LLVM.</div><div><br></div><div>Everything in CodeGen is already in a namespace, "CodeGen".  This should be renamed to "irgen".</div><div><br></div><div>Thanks for doing this!</div><div><br></div><div>John.</div></body></html>