<div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div><div class="h5"><br></div></div>
+  for (int i = 0; i != argc; ++i)<br>
+  {<br>
+    // check lenght<br>
<br>
May want to correct the typo.<br>
<br></blockquote><div><br></div><div>Fixed</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><br>
I think this should be formatted more like this to meet our coding<br>
standards (but am not 100% sure, so I will defer to others):<br>
<br>
if (ch < (UTF32)0x80)<br>
   bytesToWrite = 1;<br>
else if (ch < (UTF32)0x800)<br>
  bytesToWrite = 2;<br>
...<br>
else<br>
  ch = UNI_REPLACEMENT_CHAR;<br><br></blockquote><div><br></div><div>I haven't touched this code. I only took the function out of the section that was commented out.</div></div><br>