[cfe-dev] getLocStart versus getStartLoc

Stephen Kelly via cfe-dev cfe-dev at lists.llvm.org
Mon Jul 30 01:05:20 PDT 2018

Richard Smith via cfe-dev wrote:

> On Mon, 9 Jul 2018 at 14:06, Stephen Kelly via cfe-dev <
> cfe-dev at lists.llvm.org> wrote:
>> Stephen Kelly via cfe-dev wrote:
>> > 1) DeclarationNameInfo has both getLocEnd and getEndLoc. Both are used
>> > by calling code, and I can't tell if any use is incorrect. At any rate,
>> > if the two methods are to remain, the getLocEnd() one should be renamed
>> > to something more specific as it is the one doing something different
>> > to other getLocEnd/getEndLoc methods which generally don't 'try again'
>> > in
>> the
>> > invalid case.
>> I created a patch to inline getLocEnd() into callers.
>>  https://reviews.llvm.org/D49100

Can I commit this now? I have other things I want to get done in the clang 
codebase related to other AST issues and related to Clang.

However, all of the changes I want to make will need to be reviewed, so I 
can't really justify working on them until I can estimate whether they will 
be reviewed.

Can I just go ahead and commit that, or is there some issue with it?



More information about the cfe-dev mailing list