[cfe-dev] libclang plugin support

Stefan Kemnitz via cfe-dev cfe-dev at lists.llvm.org
Wed Aug 24 04:49:15 PDT 2016


I am working on a plugin for clang and libclang and I am having problems
with libclangs exported symbols.

The state right now of this is that D5611 and D15729 are somehow stuck.
After I did not respond fast enough, kfunk continued with D15729 which in
the end was accepted.

But there is one thing that is still not fixed.
This just works in debug mode since libclang exports all symbols in debug
In release mode the symbols that have to be exported change all the time
and providing a list of symbols to export is not an option.
I saw that others are trying to load plugins with libclang ( clang-tidy ) [[
It seems that dynamic loading still does not work like it should.

In my project I am putting these symbols into the libclang.exports file
This way i am able to load any plugin.
My plugin is made to show polyhedral optimization results from pet and
pluto in vim but it's also
possible to show clang-tidy output.
It's not limited to vim ( via YouCompleteMe ) the same thing works for
kdevelop or any other IDE that uses
libclang to parse code.

If this was already solved and i am not able to see it please tell me.
Right now I am building libclang from git ( clang 4.0 ) and it still seems
to have this problem.

Can someone help me with this ?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-dev/attachments/20160824/aea4dc73/attachment.html>

More information about the cfe-dev mailing list