[cfe-dev] [llvm-dev] Fwd: Raising CMake minimum version to 3.4.3

Renato Golin via cfe-dev cfe-dev at lists.llvm.org
Wed Apr 27 05:47:18 PDT 2016


On 27 April 2016 at 13:42, Bruce Hoult <bruce at hoult.org> wrote:
> cmake is a big dependency, but it doesn't seem to have many dependencies
> itself. They say it's just a C++ compiler and a make (not necessarily gnu).
> Probably there are one or two more than that :-)  A shell, for a start; git
> or tar/gzip etc.

It needs a compatible version of C and C++ libraries. If you build on
a modern machine but run on an older Linux, you'll get at least
libstdc++ clashes.

Also, compiling CMake and Ninja is not the most reliable way of
deploying buildbots.

What's wrong with using newer CMake features IFF you have that
version? Then you can choose where to incur the extra deployment cost
or not based on your need of that feature.

cheers,
--renato


More information about the cfe-dev mailing list