[cfe-dev] Any interest in renaming PLACEHOLDER_TYPE ?
richard at metafoo.co.uk
Sun May 5 08:07:49 PDT 2013
Seems like a reasonable idea; what do you suggest as an alternative? FWIW,
I've been using "undeduced type" to mean "type that contains a placeholder
On Sun, May 5, 2013 at 7:00 AM, Faisal Vali <faisalv at gmail.com> wrote:
> The core portion of the C++ standard denotes a "placeholder type"
> differently from its use in Clang. Since clang tends to do a nice job of
> mapping most constructs/notions from the standard into intuitive code -
> this could stand out as potentially confusing ...
> I know this is probably very low priority, but is there any interest in
> renaming PLACEHOLDER_TYPE (and the related functions), or is it too late?
> Faisal Vali
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the cfe-dev