[cfe-dev] draft rule for naming types/functions/variables

Chandler Carruth chandlerc at google.com
Mon Nov 22 21:30:01 PST 2010


Sorry, this seems to have not followed the thread, but here was my comment:

http://codereview.appspot.com/3264041/diff/1/docs/CodingStandards.html#newcode801
docs/CodingStandards.html:801: camel case (e.g. <tt>TextFileReader</tt>
and <tt>isLValue</tt>).
I would really prefer some stylistic difference between variables and
types/functions. This is mostly a problem (for me) with local variables,
where having some signifier of the locality helps me in reading it.

The most common style I have worked with is to use
under_score_separators for variables. Personally, I would advocate for
sharing this style with member variables as well, but those aren't as
important to me when reading code.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-dev/attachments/20101122/6c268be0/attachment.html>


More information about the cfe-dev mailing list