<div dir="ltr">On Mon, Dec 11, 2017 at 6:19 PM, David Blaikie <span dir="ltr"><<a href="mailto:dblaikie@gmail.com" target="_blank">dblaikie@gmail.com</a>></span> wrote:<br><div class="gmail_extra"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-style:solid;border-left-color:rgb(204,204,204);padding-left:1ex"><div dir="ltr">On Mon, Dec 11, 2017 at 3:16 PM John McCall via Phabricator <<a href="mailto:reviews@reviews.llvm.org" target="_blank">reviews@reviews.llvm.org</a>> wrote:<br><div class="gmail_quote"><span class="gmail-"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-style:solid;border-left-color:rgb(204,204,204);padding-left:1ex">rjmccall added a comment.<br>
<br>
In <a href="https://reviews.llvm.org/D41039#951648" rel="noreferrer" target="_blank">https://reviews.llvm.org/<wbr>D41039#951648</a>, @ahatanak wrote:<br>
<br>
> I had a discussion with Duncan today and he pointed out that perhaps we shouldn't allow users to annotate a struct with "trivial_abi" if one of its subobjects is non-trivial and is not annotated with "trivial_abi" since that gives users too much power.<br>
><br>
> Should we error out or drop "trivial_abi" from struct Outer when the following code is compiled?<br>
><br>
> struct Inner1 {<br>
> ~Inner1(); // non-trivial<br>
> int x;<br>
> };<br>
><br>
> struct __attribute__((trivial_abi)) Outer {<br>
> ~Outer();<br>
> Inner1 x;<br>
> };<br>
><br>
><br>
> The current patch doesn't error out or drop the attribute, but the patch would probably be much simpler if we didn't allow it.<br>
<br>
<br>
I think it makes sense to emit an error if there is provably a non-trivial-ABI component. However, for class temploids I think that diagnostic should only fire on the definition, not on instantiations; for example:<br>
<br>
template <class T> struct __attribute__((trivial_abi)) holder {<br>
T value;<br>
~holder() {}<br>
};<br>
holder<std::string> hs; // this instantiation should be legal despite the fact that holder<std::string> cannot be trivial-ABI.<br>
<br>
But we should still be able to emit the diagnostic in template definitions, e.g.:<br>
<br>
template <class T> struct __attribute__((trivial_abi)) named_holder {<br>
std::string name; // there are no instantiations of this template that could ever be trivial-ABI<br>
T value;<br>
~named_holder() {}<br>
};<br>
<br>
The wording should be something akin to the standard template rule that a template is ill-formed if it has no valid instantiations, no diagnostic required.<br>
<br>
I would definitely like to open the conversation about the name of the attribute. I don't think we've used "abi" in an existing attribute name; usually it's more descriptive. And "trivial" is a weighty word in the standard. I'm not sure I have a great counter-proposal off the top of my head, though.<br></blockquote></span><div><br>Agreed on both counts (would love a better name, don't have any stand-out candidates off the top of my head).<br><br>I feel like a more descriptive term about the property of the object would make me happier - something like "address_independent_identity" (s/identity/value/?) though, yeah, that's not spectacular by any stretch.<br></div></div></div></blockquote><div><br></div><div>Incidentally, your comments are not showing up on Phabricator for some reason.</div><div><br></div><div>The term "trivially movable" suggests itself, with two caveats:</div><div> - What we're talking about is trivial *destructive* movability, i.e. that the combination of moving the value to a new object and not destroying the old object can be done trivially, which is not quite the same as trivial movability in the normal C++ sense, which I guess could be a property that someone theoretically might care about (if the type is trivially destructed, but it isn't copyable for semantic reasons?).</div><div> - Trivial destructive movability is a really common property, and it's something that a compiler would really like to optimize based on even in cases where trivial_abi can't be adopted for binary-compatibility reasons. Stealing the term for the stronger property that the type is trivially destructively movable *and its ABI should reflect that in a specific way* would be unfortunate.</div><div><br></div><div>"trivially_movable" is a long attribute anyway, and "trivially_destructively_movable" is even worse.</div><div><br></div><div>Maybe that second point is telling us that this isn't purely descriptive — it's inherently talking about the ABI, not just the semantics of the type. I might be talking myself into accepting trivial_abi if we don't end up with a better suggestion.</div><div><br></div><div>Random thing that occurred to me: is it actually reasonable to enforce trivial_abi correctness in a non-template context? Templates aren't the only case where a user could reasonably want to add trivial_abi and just have it be suppressed if it's wrong. Imagine if some stdlib made std::string trivial_abi; someone might reasonably want to make my named_holder example above trivial_abi as well, with the expectation that it would only have an effect on targets where std::string was trivial_abi. At the very least, I'm concerned that we might be opening ourselves up to a need to add supporting features, like a way to be conditionally trivial_abi based on context.</div><div><br></div><div><a href="https://reviews.llvm.org/D41039" rel="noreferrer" target="_blank" style="font-size:12.800000190734863px">https://reviews.llvm.org/<wbr>D41039</a><br></div></div>
</div></div>