<div dir="ltr"><div>-def fpie : Flag<["-"], "fpie">, Group<f_Group>;</div><div>+def fpie : Flag<["-"], "fpie">, Group<f_Group>, Flags<[CC1Option]>;</div><div><br></div><div><br></div><div>I don't think this is the right solution as "-fpie" doesn't mean the same thing to the driver and CC1 is sort of confusing (in CC1 it doesn't mean anything by itself). Can you change the existing `-pie-level` Separate to be a CC1-only `-pic-is-pie` Flag? (name is a bikeshed)</div><div><br></div><div>With that, this LGTM. Nice cleanup!</div><div><br></div><div>-- Sean Silva</div></div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Jun 21, 2016 at 3:53 PM, Rafael EspĂ­ndola <span dir="ltr"><<a href="mailto:cfe-commits@lists.llvm.org" target="_blank">cfe-commits@lists.llvm.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">The PIC and PIE levels are not independent. In fact, if PIE is defined<br>
it is always the same as PIC.<br>
<br>
This is clear in the driver where ParsePICArgs returns a PIC level and<br>
a IsPIE boolean. Unfortunately that is currently lost and we pass two<br>
redundant levels down the pipeline.<br>
<br>
This patch keeps a bool and a PIC level all the way down to codegen. I<br>
intend to send a patch for LLVM tomorrow so that CodeGen too can be<br>
simplified.<br>
<br>
Cheers,<br>
Rafael<br>
<br>_______________________________________________<br>
cfe-commits mailing list<br>
<a href="mailto:cfe-commits@lists.llvm.org">cfe-commits@lists.llvm.org</a><br>
<a href="http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits" rel="noreferrer" target="_blank">http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits</a><br>
<br></blockquote></div><br></div>