<div dir="ltr">Also, I honestly don't see the big issue with StringSwitch. We have solved most of the bad layouting around it (I still think my marking the bug as fixed was appropriate). The only remaining issue is that we put several cases into one line which other people do with normal switch statements, too. It does not terribly hurt readability, and if it does, this can be easily fixed by adding comments.</div>
<div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, Feb 6, 2013 at 9:34 PM, Manuel Klimek <span dir="ltr"><<a href="mailto:klimek@google.com" target="_blank">klimek@google.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div dir="ltr"><div><div class="h5">On Wed, Feb 6, 2013 at 8:50 PM, Sean Silva <span dir="ltr"><<a href="mailto:silvas@purdue.edu" target="_blank">silvas@purdue.edu</a>></span> wrote:<br></div></div><div class="gmail_extra">
<div class="gmail_quote"><div><div class="h5">
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div>> Optionally derive formatting information from the input file.<br>
<br>
</div>A more sophisticated extension of this might be the solution to the<br>
"StringSwitch" issue.<br>
<br>
However, going down that road has the disadvantage that it means that<br>
the output depends on the formatting of the input, which loses (to<br>
some extent) the "canonicality" property of the formatting. (Has this<br>
been discussed elsewhere?).<br></blockquote><div><br></div></div></div><div>Yes, this comes up every time one argues with C++ devs :)</div><div>There are multiple issues at play here:</div><div>- this change only detects configuration options, it doesn't actually change the behavior depending on how code was formatted before in a non-canonical way</div>

<div>- we already configure code according to the previous whitespaces - obviously macros need this, but we also derive where comments belong to by looking at whitespace around the comment</div><div>- applying "don't touch" to StringSwitch is a pretty strong example for the other end of the spectrum, and I'd strongly vote against doing this for as long as possible ;)</div>

<div><br></div><div>Cheers,</div><div>/Manuel</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<span><font color="#888888"><br>
-- Sean Silva<br>
</font></span><div class="im"><div><div>_______________________________________________<br>
cfe-commits mailing list<br>
<a href="mailto:cfe-commits@cs.uiuc.edu" target="_blank">cfe-commits@cs.uiuc.edu</a><br>
<a href="http://lists.cs.uiuc.edu/mailman/listinfo/cfe-commits" target="_blank">http://lists.cs.uiuc.edu/mailman/listinfo/cfe-commits</a><br>
</div></div></div></blockquote></div><br></div></div>
</blockquote></div><br></div>