<div dir="ltr">From what I have gathered, people usually try not to break around "." and "->" unless it significantly enhanced readability, which it IMO doesn't in this case. But better configuration options are one of the next things on our list, so you will be able to get the old behavior back sometime soon.</div>
<div class="gmail_extra"><br><br><div class="gmail_quote">On Tue, Jan 22, 2013 at 4:36 PM, Sebastian Redl <span dir="ltr"><<a href="mailto:sebastian.redl@getdesigned.at" target="_blank">sebastian.redl@getdesigned.at</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="im"><br>
On 22.01.2013, at 15:28, Daniel Jasper wrote:<br>
<br>
> Author: djasper<br>
> Date: Tue Jan 22 08:28:24 2013<br>
> New Revision: 173160<br>
><br>
> URL: <a href="http://llvm.org/viewvc/llvm-project?rev=173160&view=rev" target="_blank">http://llvm.org/viewvc/llvm-project?rev=173160&view=rev</a><br>
> Log:<br>
> Let the formatter be more restrictive for breaking around . and -><br>
><br>
> Before:<br>
> aaaaaaaaaaaaaaa(aaaaaaaaa, aaaaaaaaa, aaaaaaaaaaaaaaaaaaaaaaa)<br>
>    .aaaaaaaaaaaaaaaaaa();<br>
><br>
> After:<br>
> aaaaaaaaaaaaaaa(aaaaaaaaa, aaaaaaaaa,<br>
>                aaaaaaaaaaaaaaaaaaaaaaa).aaaaaaaaaaaaaaaaaa();<br>
<br>
</div>Is that actually an improvement? I would prefer the former - the function call is one logical entity, so not breaking it up seems like a good idea. My company's in-house coding style rule about this is something like "break lines at the highest logical grouping possible". IOW, my logical understanding of the code here is<br>

<br>
member_access(<br>
.. call(aaaa, arguments(aaa, aaa, aaa)),<br>
.. call(aaaa)<br>
)<br>
<br>
which I realize is not equivalent to the parse tree, but I basically split this into the function call that returns an object and the member function call on that object. It makes sense to me to break between those two calls rather than in the middle of one.<br>

<span class="HOEnZb"><font color="#888888"><br>
Sebastian</font></span></blockquote></div><br></div>