<div class="gmail_quote">On Mon, Jul 2, 2012 at 5:47 PM, Jordan Rose <span dir="ltr"><<a href="mailto:jordan_rose@apple.com" target="_blank">jordan_rose@apple.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div class="im"><br>
On Jul 2, 2012, at 5:40 PM, Chandler Carruth wrote:<br>
<br>
> I'd be very happy for the diagnostic text to use more specialized terminology when it can -- I think that makes the user experience quite a bit better.<br>
><br>
> Not sure its worth having two flags though.<br>
<br>
</div>I already made Nico do that :-) and yes, I agree about the flags. I just wanted to make sure we didn't end up with something exclusively C++. ("field", of course, is just falling back to the common denominator of C.)</blockquote>
<div><br></div><div>"field" doesn't mean anything in C or in C++ (or, as far as I know, Objective-C). I'm not sure whether that makes it a great choice or a terrible choice for naming things which are either members in C, non-static data members in C++, or ivars (and @defs) in Objective-C, but that's how we currently use it. For instance:</div>
<div><br></div><div><div><stdin>:1:28: error: field has incomplete type 'X'</div><div>struct X; @interface A { X x; } @end</div><div>                           ^</div><div><stdin>:1:8: note: forward declaration of 'X'</div>
<div>struct X; @interface A { X x; } @end</div><div>       ^</div></div></div>