<br><br><div class="gmail_quote">On Thu, May 3, 2012 at 11:32 PM, Eric Christopher <span dir="ltr"><<a href="mailto:echristo@apple.com" target="_blank">echristo@apple.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div class="HOEnZb"><div class="h5"><br>
On May 1, 2012, at 8:53 AM, Alexey Samsonov <<a href="mailto:samsonov@google.com">samsonov@google.com</a>> wrote:<br>
<br>
><br>
><br>
> On Sun, Apr 29, 2012 at 3:07 AM, Eric Christopher <<a href="mailto:echristo@apple.com">echristo@apple.com</a>> wrote:<br>
>><br>
>> Sending the revised (modulo r155697) patch. Please take a look.<br>
>><br>
>> Codereview: <a href="http://codereview.appspot.com/6112056/#ps9001" target="_blank">http://codereview.appspot.com/6112056/#ps9001</a><br>
><br>
> I think about the only comment I've got is whether or not we should use comparison operators instead of == and != in these sorts of cases?<br>
><br>
> -    Dbg->EmitGlobalVariable(E->getDecl(), Init);<br>
> +    if (CGM.getCodeGenOpts().DebugInfo != CodeGenOptions::DebugLineTablesOnly)<br>
> +      Dbg->EmitGlobalVariable(E->getDecl(), Init);<br>
><br>
> I'd prefer it personally. Your thoughts?<br>
><br>
> Yes, the comparison operators look better. Using them now.<br>
> See attachment and <a href="http://codereview.appspot.com/6112056/#ps11001" target="_blank">http://codereview.appspot.com/6112056/#ps11001</a><br>
<br>
</div></div>One seemingly annoying nit: can you swap the enums so you can use >= please? I think it makes more sense. Go ahead and commit with that change.<br></blockquote><div><br></div><div>Done. Commited as r156160, thank you!</div>
</div><br clear="all"><div><br></div>-- <br><div>Alexey Samsonov, MSK</div><br>