While this change is OK w/ me (given the discusion on the issue linked) I have to wonder:<br><br><div class="gmail_quote">On Sun, Sep 25, 2011 at 4:23 PM, David Blaikie <span dir="ltr"><<a href="mailto:dblaikie@gmail.com">dblaikie@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">Rename Diagnostic to DiagnosticsEngine as per issue 5397</blockquote></div><br><div>Is that really the best naming convention? There is in fact only one DiagnosticsEngine instance per diagnostic message. All the per-message state is stored in it. Essentially, this name doesn't really compute for me.</div>
<div><br></div><div>Previously we had:</div><div><br></div><div>Diagnostic -- stored the state of a particular diagnostic, as well as a ton of other cruft.</div><div>DiagnosticInfo -- wrapper around a single Diagnostic object, most of the methods just forward</div>
<div><br></div><div>Now we have:</div><div><br></div><div>DiagnosticsEngine</div><div>Diagnostic</div><div><br></div><div>I feel like we should have split Diagnostic into two classes, one the "engine" part, the other the state for a particular diagnostic. We could call the latter "DiagnosticImpl" or something else to clarify that its just the inner storage for a Diagnostic object (in the new nomenclature). Maybe there are other ideas for better names / designs?</div>