[PATCH] D56430: Incorrect implicit data-sharing for nested tasks

Alexey Bataev via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Tue Jan 8 06:38:25 PST 2019


ABataev added inline comments.


================
Comment at: lib/Sema/SemaOpenMP.cpp:680
+
+bool isParallelRegion(OpenMPDirectiveKind DKind) {
+  return isOpenMPParallelDirective(DKind) || isOpenMPTeamsDirective(DKind);
----------------
Better to rename it to `isImplicitTaskingRegion`


Repository:
  rC Clang

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D56430/new/

https://reviews.llvm.org/D56430





More information about the cfe-commits mailing list