[PATCH] D56158: [sanitizer_common] Implement funopen*() interceptors for NetBSD

Kamil Rytarowski via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Sun Dec 30 07:02:45 PST 2018


krytarowski added inline comments.


================
Comment at: lib/sanitizer_common/sanitizer_common_interceptors.inc:9150
+
+static int wrapped_read(void *cookie, char *buf, int len) {
+  COMMON_INTERCEPTOR_UNPOISON_PARAM(3);
----------------
How about `wrapped_funopen_read` etc? It won't clash with future potential inteceptors with so generic names.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D56158/new/

https://reviews.llvm.org/D56158





More information about the cfe-commits mailing list