[PATCH] D55363: [clangd] Expose FileStatus in LSP.

Haojian Wu via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Mon Dec 17 05:53:30 PST 2018


hokein added a comment.

> Sorry if I missed any important design discussions here, but wanted to clear up what information we are trying to convey to the user with the status messages?
>  E.g. why seeing "building preamble", "building file" or "queued" in the status bar can be useful to the user? Those messages mention internals of clangd, I'm not sure how someone unfamiliar with internals of clangd should interpret this information.

Leaking some details to users is fine -- it can help users build the model of how clangd work, even though they don't understand all details, users will workout "building file" will take a while before "idle", and when the file is idle, clangd is responsive for upcoming requests.
I also agree that we should try to avoid using terms that C++ programmers are unfamiliar with.

> Good point, we should definitely state it's a clangd-specific extension. We could come up with a naming scheme for our extensions. I would propose something like clangd:$methodName, i.e. the current extensions would be clangd:textDocument/fileStatus.

Adding clang-specific words to clangd-extension methods sounds good to me (to avoid confusion, the extension `textDocument/switchFromHeader` confused me before). I'd vote for `textDocument/clangd.FileStatus`.


Repository:
  rCTE Clang Tools Extra

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D55363/new/

https://reviews.llvm.org/D55363





More information about the cfe-commits mailing list