[PATCH] D47135: [analyzer][WIP] A checker for dangling string pointers in C++

Reka Kovacs via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Tue May 22 13:18:56 PDT 2018

rnkovacs added a comment.

Thanks for your comments!

It would be nice if we could reach a consensus on the naming issue before I update the patch. I was wondering, as we plan to support stuff like `std::vector::data()`, which is not a string, and `std::string_view`, which is not strictly a pointer, could we perhaps go with something like `DanglingInternalBufferHandle`? The `AllocationFamily` could similarly be `AF_InternalBuffer`. What do you think?

  rC Clang


More information about the cfe-commits mailing list