[PATCH] D39829: add new check for property declaration
Yan Zhang via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri Nov 10 02:19:50 PST 2017
Wizard added inline comments.
Comment at: test/clang-tidy/objc-property-declaration.m:8
+ at property(assign, nonatomic) int camelCase;
+// CHECK-MESSAGES-NOT: :[[@LINE-1]]:34: warning: property 'camelCase' is not in proper format according to property naming convention [objc-property-declaration]
+ at end
> Why does the check catch this case? Isn't `camelCase` a correct name?
This is CHECK-MESSAGES-NOT
More information about the cfe-commits