[PATCH] D39220: [Analyzer] Store BodyFarm in std::unique_ptr

George Karpenkov via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Tue Oct 24 16:47:53 PDT 2017

george.karpenkov added inline comments.

Comment at: include/clang/Analysis/AnalysisDeclContext.h:424
   /// methods during the analysis.
-  BodyFarm *BdyFrm = nullptr;
+  std::unique_ptr<BodyFarm> BdyFrm;
alexfh wrote:
> BdyFrm is somewhat cryptic. Maybe Farm, Bodies or something else that  is not so weirdly abbreviated?
But that's just forced on us by the naming convention, isn't it? I think other names are worse though: they don't tell us which class we can look at to figure out what is it doing.


More information about the cfe-commits mailing list