[PATCH] D21113: Add support for case-insensitive header lookup

Saleem Abdulrasool via cfe-commits cfe-commits at lists.llvm.org
Tue Jun 7 19:25:11 PDT 2016


compnerd added a comment.

This looks good to me.  Thanks for picking this up!  And thanks for the perf numbers!


================
Comment at: lib/Basic/VirtualFileSystem.cpp:401
@@ +400,3 @@
+    IntrusiveRefCntPtr<FileSystem> Base)
+    : Base(Base) {}
+
----------------
Probably can inline this in the header.

================
Comment at: lib/Basic/VirtualFileSystem.cpp:410
@@ +409,3 @@
+  std::error_code EC;
+  directory_iterator I = Base->dir_begin(Dir, EC), E;
+
----------------
Thats slightly difficult to read (the `E` directory_iterator.

================
Comment at: lib/Basic/VirtualFileSystem.cpp:481
@@ +480,3 @@
+  return Base->setCurrentWorkingDirectory(Path);
+}
+
----------------
These two can probably be inlined into the header.


http://reviews.llvm.org/D21113





More information about the cfe-commits mailing list