[PATCH] D20429: [clang-tidy] Handle using-decls with more than one shadow decl.

Haojian Wu via cfe-commits cfe-commits at lists.llvm.org
Fri May 20 01:19:19 PDT 2016


hokein marked 2 inline comments as done.

================
Comment at: clang-tidy/misc/UnusedUsingDeclsCheck.cpp:59
@@ -59,1 +58,3 @@
             /*SkipTrailingWhitespaceAndNewLine=*/true));
+    for (const auto It : Using->shadows()) {
+      const auto *TargetDecl = It->getTargetDecl()->getCanonicalDecl();
----------------
alexfh wrote:
> It's not iterator, so `It` is a confusing name. Something along the lines of `Shadow` or `UsingShadow` should be better.
Actually, the `Using->shadows()` returns an iterator range, but I'm fine renaming it here.


http://reviews.llvm.org/D20429





More information about the cfe-commits mailing list