[PATCH] D14616: [libcxx] Replace TEST_HAS_NO_EXCEPTIONS with _LIBCPP_NO_EXCEPTIONS [NFC]

Asiri Rathnayake via cfe-commits cfe-commits at lists.llvm.org
Thu Nov 12 07:33:43 PST 2015


rmaprath created this revision.
rmaprath added reviewers: EricWF, jroelofs, mclow.lists, rengolin.
rmaprath added a subscriber: cfe-commits.

The macro TEST_HAS_NO_EXCEPTIONS seems to be defined very similar to _LIBCPP_NO_EXCEPTIONS, I'm thinking of getting rid of the former as the latter is more general (defined in __config).

I'm curious as to why the TEST_HAS_NO_EXCEPTIONS macro was introduced? Until very recently, we did not have any -fno-exceptions test runs AFAIK.

If readability is the reason for this macro, we can instead do:

```
#define TEST_HAS_NO_EXCEPTIONS _LIBCPP_NO_EXCEPTIONS
```

No functional changes.

http://reviews.llvm.org/D14616

Files:
  test/std/experimental/any/any.class/any.assign/copy.pass.cpp
  test/std/experimental/any/any.class/any.assign/value.pass.cpp
  test/std/experimental/any/any.class/any.cons/copy.pass.cpp
  test/std/experimental/any/any.class/any.cons/move.pass.cpp
  test/std/experimental/any/any.class/any.cons/value.pass.cpp
  test/std/experimental/any/any.nonmembers/any.cast/any_cast_reference.pass.cpp
  test/support/any_helpers.h
  test/support/test_macros.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D14616.40047.patch
Type: text/x-patch
Size: 4044 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20151112/720a0626/attachment-0001.bin>


More information about the cfe-commits mailing list