[PATCH] Refactor the formatter of clang-format.

Manuel Klimek klimek at google.com
Fri May 8 01:35:28 PDT 2015


Hi djasper,

Pull various parts of the UnwrappedLineFormatter into their own abstractions.
NFC.

There are two things left for subsequent changes (to keep this reasonably small)
- the UnwrappedLineFormatter now has a bad name
- the UnwrappedLineFormatter::format function is still too large

The current plan is to rename the UnwrappedLineFormatter into BlockFormatter,
put more of the local variables of format() into class members (perhaps add
an abstraction for keeping track of the indent levels), and split format() up.

http://reviews.llvm.org/D9597

Files:
  lib/Format/Format.cpp
  lib/Format/UnwrappedLineFormatter.cpp
  lib/Format/UnwrappedLineFormatter.h

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D9597.25288.patch
Type: text/x-patch
Size: 37274 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20150508/4b13b7ad/attachment.bin>


More information about the cfe-commits mailing list