[PATCH] Include checker name in Static Analyzer PLIST output
zaks.anna at gmail.com
Mon Jan 12 23:10:25 PST 2015
Jordan has pointed out that a similar discussion has occurred when the getCheckName method has been added to the diagnostic. There are several write-ups from Ted and Jordan about issue tracking there as well. (See the "Future directions for the analyzer" thread on cfe-dev as well as the review comments for the patch that added the getCheckName method. It's about a year old.)
Note that we do not guarantee that CheckName will never change. (At some point, we will want to clean up our naming of the checks.) We also do not guarantee that the CheckName will be the same as the checker name (these should be the names of bug types, not of the implementation module). On the other hand, we do not expect to continuously change these.
Since the getCheckName is already part of the diagnostic, it's fine to add it to the plist output. The name of the field does need to change to check_name. (This highlights that these are not guaranteed to be checker names.)
What do you think?
If you are ok with this, could you rename the field and I'll commit the patch.
More information about the cfe-commits