[PATCH] Rename flag_enum to enum_role

Sean Silva chisophugis at gmail.com
Thu Jan 8 16:04:30 PST 2015


A couple drive-by comments; not trying to formally become a reviewer on the patch.


================
Comment at: lib/Sema/SemaDecl.cpp:13786
@@ -13785,2 +13785,3 @@
+      if (InitVal != 0 && !IsValueInOptionsEnum(Enum, InitVal, true))
         Diag(ECD->getLocation(), diag::warn_flag_enum_constant_out_of_range)
           << ECD << Enum;
----------------
Should we change the name of `diag::warn_flag_enum_constant_out_of_range` if we are no longer using the flag_enum nomenclature?

================
Comment at: test/Sema/attr-flag-enum.c:3
@@ -2,3 @@
-
-enum __attribute__((flag_enum)) flag {
-  ea = 0x1,
----------------
Just doublechecking: we are no longer accepting flag_enum, right? Is there a potential compatibility issue?

http://reviews.llvm.org/D6847

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the cfe-commits mailing list