[PATCH] [Driver] Move description of toolchain specific include directories from the common driver code to the corresponding `MultilibSet` declarations

Rafael Ávila de Espíndola rafael.espindola at gmail.com
Tue Aug 5 08:19:05 PDT 2014

The code change seems reasonable if the flexibility of a callback is needed. I have no opinion on whether it is.

Do you have the followup change where this is used?

Comment at: include/clang/Driver/Multilib.h:158
@@ -152,1 +157,3 @@
+  MultilibSet &includeDirsCallback(IncludeDirsFunc F) {
+    IncludeCallback = F;
setincludeDirsCallback would be the correct name, no?


More information about the cfe-commits mailing list