r203261 - [C++11] Replacing IndirectFieldDecl iterators chain_begin() and chain_end() with iterator_range chains(). Updating all of the usages of the iterators with range-based for loops.

Aaron Ballman aaron at aaronballman.com
Sat Mar 8 10:39:52 PST 2014


On Sat, Mar 8, 2014 at 1:09 PM, Sean Silva <silvas at purdue.edu> wrote:
>
>
>
> On Fri, Mar 7, 2014 at 1:31 PM, Richard Smith <richard at metafoo.co.uk> wrote:
>>
>>
>> On 7 Mar 2014 10:21, "Aaron Ballman" <aaron at aaronballman.com> wrote:
>> >
>> > Author: aaronballman
>> > Date: Fri Mar  7 12:11:58 2014
>> > New Revision: 203261
>> >
>> > URL: http://llvm.org/viewvc/llvm-project?rev=203261&view=rev
>> > Log:
>> > [C++11] Replacing IndirectFieldDecl iterators chain_begin() and
>> > chain_end() with iterator_range chains(). Updating all of the usages of the
>> > iterators with range-based for loops.
>>
>> This one should be "chain", not "chains".
>
>
> What is the official convention here? There was a recent thread about this
> but I didn't see any conclusion. Are you going for foo_begin/foo_end/foo? I
> actually like that better than my foo_range suggestion.

Basically: foo_begin/foo_end -> foos(). If "foo" is an abbreviation
which we usually spell out, then it'd be foobars() instead of foos().

~Aaron



More information about the cfe-commits mailing list