[PATCH] clang-cl: add support for /? and /help
chandlerc at gmail.com
Fri Jul 26 12:05:10 PDT 2013
We can definitely get this in I think. =] Commented on one API/naming issue.
Comment at: include/clang/Driver/Driver.h:400-402
@@ +399,5 @@
+ /// \brief Determine option flags to include/exclude based on driver mode.
+ void MakeIncludeExcludeFlags(unsigned &FlagsToInclude,
+ unsigned &FlagsToExclude) const;
I'd really love to have better names here, but don't have a lot of good ideas... "makeIncludeExcludeFlagMasks" maybe. Definitely follow the fancy new naming standard. I would also suggest "IncludedFlagsBitmask" or some such as a pattern throughout. s/Bitmask/Mask/ if you like, i don't care deeply.
Also, it would be good to specify the expected input and output semantics for the two parameters. Are they pure output parameters? If so, I would suggest a pair and using llvm::tie when calling it.
More information about the cfe-commits