[PATCH] [ms-cxxabi] Implement vbtable name mangling

Timur Iskhodzhanov timurrrr at google.com
Tue May 21 11:53:42 PDT 2013



================
Comment at: lib/CodeGen/CGVTables.cpp:762
@@ +761,3 @@
+  void findUnambiguousPaths(const CXXRecordDecl *CurBase,
+                            const CXXRecordDecl *ForBase,
+                            CharUnits CurOffset,
----------------
forgot to update the parameter name here?

================
Comment at: lib/CodeGen/CGVTables.cpp:822
@@ +821,3 @@
+    CharUnits NextOffset;
+    const CXXRecordDecl *NextReusingBase = Base;
+    if (I->isVirtual()) {
----------------
I think this name is a bit better.

Can you please put an overview comment describing when vbptrs are reused?
While writing that comment you may also come up with even better names :)

================
Comment at: lib/CodeGen/CGVTables.cpp:810
@@ +809,3 @@
+    VBTablePath *Info = new VBTablePath(
+      VBTableInfo(ReusingBase, BaseSubobject(CurBase, CurOffset), /*GV=*/0));
+    Paths.push_back(Info);
----------------
Hm, wdyt about merging CurBase with CurOffset into BaseSubobject ?


http://llvm-reviews.chandlerc.com/D636



More information about the cfe-commits mailing list