[PATCH] New ASTMatcher and enhancement to hasOverloadedOperatorName

Manuel Klimek klimek at google.com
Wed Mar 6 07:56:53 PST 2013


  LG after name change :)


================
Comment at: include/clang/ASTMatchers/ASTMatchers.h:1830
@@ +1829,3 @@
+/// varDecl(hasType(qualType(canonicalType(referenceType())))))) does.
+AST_MATCHER_P(QualType, canonicalType, internal::Matcher<QualType>,
+              InnerMatcher) {
----------------
Calling it "hasCanonicalType" matches better with our current naming scheme, in which only elements of the AST (basically things for which classes with that name exist) have matchers without verbs.


http://llvm-reviews.chandlerc.com/D494

BRANCH
  matchers

ARCANIST PROJECT
  clang



More information about the cfe-commits mailing list