r176525 - doc. parsing. Improve on diagnostics on my last patch.

Douglas Gregor dgregor at apple.com
Tue Mar 5 21:35:16 PST 2013



Sent from my iPhone

On Mar 5, 2013, at 3:53 PM, Jordan Rose <jordan_rose at apple.com> wrote:

> 
> On Mar 5, 2013, at 15:51 , jahanian <fjahanian at apple.com> wrote:
> 
>> 
>> On Mar 5, 2013, at 3:37 PM, Jordan Rose <jordan_rose at apple.com> wrote:
>> 
>>> I hate to continue bikeshedding here, but why is this not just a single warning with a %select and associated enum { Function, Callback, Method }?
>>> 
>>> Also, "Objective-C" should not be lowercase.
>> 
>> No particular reason. I see that objective-c is being used throughout clang source in comments.
> 
> I meant the diagnostic text:
> 
> +def warn_doc_method_not_attached_to_a_objc_method_decl : Warning<
> +  "'%select{\\|@}0method' command should be used in a comment attached to an "
> +  "objective-c method declaration">,
> 
> 
> I'm not really happy about it being lowercase in the source either, but you're right that that's hardly uncommon.

Still, we should just fix it. The language is spelled Objective-C. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20130305/9c3bc974/attachment.html>


More information about the cfe-commits mailing list