[cfe-commits] [PATCH 3/5] [clang.py] Implement Type.arguments()
tobias at grosser.es
Sun Feb 19 00:49:07 PST 2012
On 02/19/2012 05:39 AM, Gregory Szorc wrote:
> Does anyone else think that "arguments" may not be the best name?
> Perhaps "argument_types" would be more suitable...
Yes. I agree. Either name it argument_types, or return a class called
'argument' that than has a .type() function. Returning a class is
probably overhead, as it would only have a single function. I would just
name the iterator argument_types().
Also, I just realized you define the __iter__(self) method. Why is that
needed? Diagnostic.ranges() gets away without using it?
More information about the cfe-commits