[cfe-commits] [PATCH] Fix getcontext builtin

Dimitry Andric dimitry at andric.com
Fri Nov 11 07:20:42 PST 2011


On 2011-11-10 01:24, Douglas Gregor wrote:
> On Nov 9, 2011, at 3:10 PM, Rafael EspĂ­ndola wrote:
...
>> dgregor, do these numbers have to be stable?
> We're prefer to keep the numbers stable. Plus, that new enumerator name is certainly not following the naming convention for these enumerators.

Actually, the other enumerators for typedef types use the same
capitalization as the original types:

      SPECIAL_TYPE_FILE                        = 3,
      /// \brief C jmp_buf typedef type
      SPECIAL_TYPE_jmp_buf                     = 4,
      /// \brief C sigjmp_buf typedef type
      SPECIAL_TYPE_sigjmp_buf                  = 5,

In any case, I've now put the ucontext_t-related enumerator at the end.
Updated patch attached.


>> and adding a warning to test/Misc/warning-flags.c is not OK.

Until I read the top of that file, I didn't realize that it was meant to
shrink instead of grow, sorry. :)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: fix-getcontext-builtin-2.diff
Type: text/x-diff
Size: 8592 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20111111/dd1619ee/attachment.diff>


More information about the cfe-commits mailing list