[cfe-commits] r140478 - in /cfe/trunk: include/clang/ARCMigrate/ include/clang/AST/ include/clang/Basic/ include/clang/CodeGen/ include/clang/Driver/ include/clang/Frontend/ include/clang/Index/ include/clang/Lex/ include/clang/Parse/ include/cla

Chandler Carruth chandlerc at google.com
Sun Sep 25 17:02:07 PDT 2011


While this change is OK w/ me (given the discusion on the issue linked) I
have to wonder:

On Sun, Sep 25, 2011 at 4:23 PM, David Blaikie <dblaikie at gmail.com> wrote:

> Rename Diagnostic to DiagnosticsEngine as per issue 5397


Is that really the best naming convention? There is in fact only one
DiagnosticsEngine instance per diagnostic message. All the per-message state
is stored in it. Essentially, this name doesn't really compute for me.

Previously we had:

Diagnostic -- stored the state of a particular diagnostic, as well as a ton
of other cruft.
DiagnosticInfo -- wrapper around a single Diagnostic object, most of the
methods just forward

Now we have:

DiagnosticsEngine
Diagnostic

I feel like we should have split Diagnostic into two classes, one the
"engine" part, the other the state for a particular diagnostic. We could
call the latter "DiagnosticImpl" or something else to clarify that its just
the inner storage for a Diagnostic object (in the new nomenclature). Maybe
there are other ideas for better names / designs?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20110925/badad14d/attachment.html>


More information about the cfe-commits mailing list