[cfe-commits] [Review] rollingout ASTContext::getTypeSizeInBytes()
clattner at apple.com
Thu Nov 26 12:39:31 PST 2009
>> I was thinking more along the lines of a type that represented a
>> size/offset in bytes; call it bytes_t for the sake of argument.
> Okay. As a nested class in ASTContext? Or as a stand-alone class?
> Since we're making changes to the API anyways, what do you think of the
> units being bytes? The getTypeSizeInBytes() method returns the size of
> the type in characters, so it would be more accurate to call the units
> chars_t. And if we're doing that, we might as well change the method
> names to 'getTypeSizeInChars()' and 'getCharWidth()', too.
I really prefer it to be called CharUnits or something like that instead of 'bytes'. Bytes will confuse us forever going forward :)
More information about the cfe-commits