[cfe-commits] r56692 - in /cfe/trunk: Driver/PrintPreprocessedOutput.cpp include/clang/Basic/SourceManager.h include/clang/Lex/DirectoryLookup.h include/clang/Lex/HeaderSearch.h include/clang/Lex/PPCallbacks.h lib/Basic/SourceManager.cpp lib/Driv

Daniel Dunbar daniel at zuster.org
Fri Oct 24 14:38:15 PDT 2008


On Fri, Sep 26, 2008 at 2:18 PM, Chris Lattner <sabre at nondot.org> wrote:

>
> +  /// Characteristic_t - This is used to represent whether a file or
> directory
> +  /// holds normal user code, system code, or system code which is
> implicitly
> +  /// 'extern "C"' in C++ mode.  Entire directories can be tagged with
> this
> +  /// (this is maintained by DirectoryLookup and friends) as can specific
> +  /// FileIDInfos when a #pragma system_header is seen or various other
> cases.
> +  ///
> +  enum Characteristic_t {
> +    C_User, C_System, C_ExternCSystem
> +  };
> +


Why Characteristic_t? Do we have any precedent for this naming convention?

Lately I find myself wishing we had some more style guidelines, clang has a
rich diversity of naming conventions in it. ;)
I don't really want to start a discussion of what is best, I just want
things to be self consistent.

 - Daniel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20081024/315250ea/attachment.html>


More information about the cfe-commits mailing list