[all-commits] [llvm/llvm-project] 96ae43: [Bitstream] Use alignTo to make code more readable...

topperc via All-commits all-commits at lists.llvm.org
Tue Sep 1 11:07:12 PDT 2020


  Branch: refs/heads/master
  Home:   https://github.com/llvm/llvm-project
  Commit: 96ae43bad5b86aad90a9820d2e3c1a51f0af8a75
      https://github.com/llvm/llvm-project/commit/96ae43bad5b86aad90a9820d2e3c1a51f0af8a75
  Author: Craig Topper <craig.topper at intel.com>
  Date:   2020-09-01 (Tue, 01 Sep 2020)

  Changed paths:
    M llvm/lib/Bitstream/Reader/BitstreamReader.cpp

  Log Message:
  -----------
  [Bitstream] Use alignTo to make code more readable. NFC

I was recently debugging a similar issue to https://reviews.llvm.org/D86500 only with a large metadata section. Only after I finished debugging it did I discover it was fixed very recently.

My version of the fix was going to alignTo since that uses uint64_t and improves the readability of the code. So I though I would go ahead and share it.

Differential Revision: https://reviews.llvm.org/D86957




More information about the All-commits mailing list