[all-commits] [llvm/llvm-project] a1dfd6: [X86] Add helper function to reduce some code dupl...

topperc via All-commits all-commits at lists.llvm.org
Wed May 27 01:32:43 PDT 2020


  Branch: refs/heads/master
  Home:   https://github.com/llvm/llvm-project
  Commit: a1dfd6d828ac4f8e11e8013b952f0ef080890dcf
      https://github.com/llvm/llvm-project/commit/a1dfd6d828ac4f8e11e8013b952f0ef080890dcf
  Author: Craig Topper <craig.topper at gmail.com>
  Date:   2020-05-27 (Wed, 27 May 2020)

  Changed paths:
    M llvm/lib/Target/X86/X86ISelLowering.cpp

  Log Message:
  -----------
  [X86] Add helper function to reduce some code duplication when shrinking a vector load to a vzext_load.

There's more code for calling CombineTo and replacing the nodes
that I'd like to share, but its complicated by the getNode call
in the middle that needs to be specific to each opcode.

While there are also make sure we recursively delete the load
we're replacing. It eventually gets removed by a RemoveDeadNodes
call at the end of DAG combine, but we should be more eager about
it. We were inconsistently doing this in some places but not all.




More information about the All-commits mailing list