[all-commits] [llvm/llvm-project] 24ee4e: [PowerPC][NFC] Rename record instructions to use _...

jsji via All-commits all-commits at lists.llvm.org
Mon Jan 6 14:27:29 PST 2020


  Branch: refs/heads/master
  Home:   https://github.com/llvm/llvm-project
  Commit: 24ee4edee8e00bb7ad3d3cda17d02a442456ff3e
      https://github.com/llvm/llvm-project/commit/24ee4edee8e00bb7ad3d3cda17d02a442456ff3e
  Author: Jinsong Ji <jji at us.ibm.com>
  Date:   2020-01-06 (Mon, 06 Jan 2020)

  Changed paths:
    M llvm/lib/Target/PowerPC/AsmParser/PPCAsmParser.cpp
    M llvm/lib/Target/PowerPC/P9InstrResources.td
    M llvm/lib/Target/PowerPC/PPCISelDAGToDAG.cpp
    M llvm/lib/Target/PowerPC/PPCISelLowering.cpp
    M llvm/lib/Target/PowerPC/PPCISelLowering.h
    M llvm/lib/Target/PowerPC/PPCInstr64Bit.td
    M llvm/lib/Target/PowerPC/PPCInstrAltivec.td
    M llvm/lib/Target/PowerPC/PPCInstrFormats.td
    M llvm/lib/Target/PowerPC/PPCInstrHTM.td
    M llvm/lib/Target/PowerPC/PPCInstrInfo.cpp
    M llvm/lib/Target/PowerPC/PPCInstrInfo.td
    M llvm/lib/Target/PowerPC/PPCInstrVSX.td
    M llvm/lib/Target/PowerPC/PPCMIPeephole.cpp
    M llvm/test/CodeGen/PowerPC/block-placement.mir
    M llvm/test/CodeGen/PowerPC/convert-rr-to-ri-instrs-out-of-range.mir
    M llvm/test/CodeGen/PowerPC/convert-rr-to-ri-instrs.mir
    M llvm/test/CodeGen/PowerPC/fold-rlwinm.mir
    M llvm/test/CodeGen/PowerPC/ifcvt-diamond-ret.mir
    M llvm/test/CodeGen/PowerPC/opt-cmp-inst-cr0-live.ll
    M llvm/test/CodeGen/PowerPC/opt-sub-inst-cr0-live.mir
    M llvm/test/CodeGen/PowerPC/peephole-miscompile-extswsli.mir
    M llvm/test/CodeGen/PowerPC/rlwinm_rldicl_to_andi.mir

  Log Message:
  -----------
  [PowerPC][NFC] Rename record instructions to use _rec suffix instead of o

We use o suffix to indicate record form instuctions,
(as it is similar to dot '.' in mne?)

This was fine before, as we did not support XO-form.
However, with https://reviews.llvm.org/D66902,
we now have XO-form support.

It becomes confusing now to still use 'o' for record form,
and it is weird to have something like 'Oo' .

This patch rename all 'o' instructions to use '_rec' instead.
Also rename `isDot` to `isRecordForm`.

Reviewed By: #powerpc, hfinkel, nemanjai, steven.zhang, lkail

Differential Revision: https://reviews.llvm.org/D70758




More information about the All-commits mailing list